Skip to main content
Skip table of contents

Release 3.7, 3.8, 3.9 - Major compatibility upgrades

We create separate release numbers to signal major changes in code. However, the code is still improving 🤩 . The bugfixes are important and upgrading is required if you want to remain in good practices about security and reliability of data.

Notable aspects:

  • 3.9 EDGE: Compatibility with Confluence 8.9 (published on 18/04/2024).

    • We’ve changed a lot of code, due to new Confluence APIs. We recommend waiting for two weeks before upgrading.

    • Drop support for Java 8.

    • Progressive rell-out: We’ll first mark this release as only compatible with Confluence 8.9, then roll out for 8.8, 8.7, etc. In reality, this release is compatible with Confluence 7.19 as long as it has Java 11 (7.19 is the last compatible with Java 8).

    • PSEA must be upgraded to 2.0, if present (optional).

    • See our Compatibility matrix.

  • 3.8 RECOMMENDED: Compatibility with Confluence 8.8,

    • A major improvement to the indexation was added in 3.8.1, which created errorneous data (requirements seemed linked to page versions).

  • 3.7: Compatibility with Confluence 8.7.

    • (warning) Due to an indexation error creating wrong data, we recommend upgrading to 3.7.5, 3.8.1 or above.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.