Skip to main content
Skip table of contents

Compatibility matrix

This table displays the version of Requirement Yogi to use with the version of Confluence and Jira.

Our guideline: We aim to support LTS versions of Confluence and Jira for 2 years.

Confluence version

RY versions

Java version
(Default / supported)

Published

End of support

Confluence 9.0

To be determined

Dropping support for Java 11[1]

Mid-2024 ?

Confluence 8.8

3.7.5—present

Java 17 / 11

February 2024

(Non-LTS)

Confluence 8.7

3.6.13—present

Java 17 / 11

December 2023

(Non-LTS)

Confluence 8.5.6 LTS and above

3.7.5—present

Java 17 / 11

February 2024

August 2025

Confluence 8.5.0 LTS

3.6.0—3.7.4

Java 17 / 11

August 2023

Use 8.5.6

Confluence 8.0

3.4.9—present

Java 11

November 2022

(Non-LTS)

Confluence 7.20

3.4.6—present

Java 11 / 8

October 2022

(Non-LTS)

Confluence 7.19 LTS

3.3.10—present (warning)[2]

Java 11 / 8

July 2022

January 2024 (warning)[2]

Confluence 7.13 LTS

2.6.12—3.5.8

Java 11 / 8

August 2021

August 2023

[2]As an exception, we are expecting to shorten the duration of the support for Confluence 7.19 (1.5 instead of 2 years), and require Confluence 8.5 sooner than expected, because of difficult API changes coming up in Confluence 8.7, 8.8 and 9.0.

Jira version

RYJ versions

Java version
(Default / supported)

Published

End of support

Jira 9.12 LTS

3.6.3—present

Java 17 / 8

November 2023

November 2025

Jira 9.10

3.5.5—present

Java 11 / 8

June 2023

(Non-LTS)

Jira 9.4 LTS

3.4.9—present

Java 11 / 8

November 2022

November 2024

Jira 8.20 LTS

3.0.3—3.6.3

Java 11 / 8

October 2021

October 2023

Jira 8.13 LTS

2.5.11—3.6.3

Java 8

October 2020

October 2023

References:

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.